GN and T-Type Performance Enthusiasts (GNTTYPE) Forums GN and T-Type Performance Enthusiasts (GNTTYPE) Forums
This is a general site search and does not include list archives.

Go Back   GN and T-Type Performance Enthusiasts (GNTTYPE) Forums > Members List

quickdave is on a distinguished road

quickdave quickdave is offline

Visitor Messages

Showing Visitor Messages 1 to 1 of 1
  1. quickdave
    05-19-2013 07:46 PM
    quickdave
    Ok here goes,, I have obtained a great deal of info from this site!!! Great job guys.


    Problem: Car gets really hot 240 degrees,,,

    The rest of the story:

    This car is a 87 T, it sat for 5 years but was started every 2 weeks but not necessarily driven every 2 weeks. It was unlicensed and needed smog,, (Cali)

    According to the scan tool,, all settings are just about right on and it runs great. I replaced the the thermostat with a 160 degree one,, getting it out was a bear... flushed the radiator and thought I had solved the problem. On previous drives around town, it didnt get that warm or I didnt notice it but the overflow would fill up a bit,, when it cooled it would suck all the fluid back into radiator. On a recent trip to Riverside area,, up some big hills,, outside temp was 94 degrees and my AC does not work , yea it was hot, the temp climbed to about 140 but i knew it would cool once I went down the hills and slowed my speed. What I noticed was my overflow was pretty full and when the car cooled,, it did not suck back into radiator. I drove the car back to house later that weekend with the air temp at about 80, car temp never got over 230 just up the big hills again. I know this is kind of high. I also know that my high speed fan is working but my delay fan does not.. Question is could the radiator be full of crud and only partly working?
    Also the previous owner raced this car,, he added another tranny cooler to the front of the radiator in line with the one built into the radiator.
    Should I re-core or get another,, Fans? Thanks for the help ahead of time.. I sure hope this posts correctly... Dave

About Me

  • About quickdave
    City
    San Diego
    State
    Ca.
    Country
    usa
    First Vehicle
    87 Grand National
    First Vehicle Comments
    It was worked!! had some cool gadgets and a killer stereo. I was 4-5th owner, ran great but it did need a complete engine and tranny overhaul.. had to let er go!
    Second Vehicle
    87 Turbo T
    Second Vehicle Comments
    AKA Frankenstein... long story two cars in one...

Statistics

Total Posts
Visitor Messages
General Information
  • Last Activity: 01-29-2014 01:36 AM
  • Join Date: 04-24-2012
  • Referrals: 0

All times are GMT -4. The time now is 05:54 PM.


This page maintained by: gnttype-webmaster@gnttype.org

The content, images, text and multimedia displayed and contributed by the members of the Grand National and T-Type Performance Enthusiasts Organization are Copyright ©1996-2005. No part, section, image, article or whole of this site may be reposted or redisplayed without permission of the author/contributor and/or the Grand National and T-Type Performance Enthusiasts Organization.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.