GN and T-Type Performance Enthusiasts (GNTTYPE) Forums

GN and T-Type Performance Enthusiasts (GNTTYPE) Forums (http://gnttype.org/forums/index.php)
-   Turbo Regal FAQs (http://gnttype.org/forums/forumdisplay.php?f=42)
-   -   Brake systems on Turbo Regals (http://gnttype.org/forums/showthread.php?t=14300)

MikeRutledge 09-26-2010 09:52 PM

Brake systems on Turbo Regals
 
86 Grand National Did all of them or any have powermaster brakes Hydroboost or vacuum and if so how can you tell what your car is supposed to have?

kenmosher 05-03-2011 01:49 PM

Re: Brake systems on Turbo Regals
 
The 1984-85 cars had the Hydroboost system with the LM9 engine.

The 1986-87 cars had the PowerMaster (electric) system.

Oregon87T 09-10-2013 06:06 PM

Re: Brake systems on Turbo Regals
 
Quote:

Originally Posted by kenmosher (Post 58498)
The 1984-85 cars had the Hydroboost system with the LM9 engine.

The 1986-87 cars had the PowerMaster (electric) system.

What exactly is it that goes "wrong" with the PowerMaster system? My car has 32,xxx miles and is flawless but all original. What % of them go bad and what happens, Ken?

Sorry I know a broad question, but I still haven't seen EXACTLY what part it is that apparently fails a lot.



thanks!

kenmosher 11-20-2013 01:03 PM

Re: Brake systems on Turbo Regals
 
The accumulator bulb is probably the #1 failure. It looses the high pressure nitrogen gas charge eventually. My 45K mile car has gone through at least 3 of them that I can remember.

The brake switch on the unit sometimes will develop a leak around the connector (and there was an early recall to replace the switch with a new design).

Occaisonally the pump motor will die ... usually from running too much/too long due to leaking internal seals in the MC or a bad accumulator.


All times are GMT -4. The time now is 04:03 AM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.