GN and T-Type Performance Enthusiasts (GNTTYPE) Forums GN and T-Type Performance Enthusiasts (GNTTYPE) Forums
This is a general site search and does not include list archives.

Go Back   GN and T-Type Performance Enthusiasts (GNTTYPE) Forums > Technical Topics > Driveability / Troubleshooting

Reply
 
Thread Tools Display Modes
  #1  
Old 02-12-2019, 01:01 PM
phil errett phil errett is offline
New Member
 
Join Date: May 2007
Location: Ontario
Posts: 19
phil errett is on a distinguished road
Default Engine bogs at WOT

My 84 GN is in a shop and the owner is searching for a Snap On red brick so he can pull diagnostics, so I though I would try with you guys again.

I have searched the board and cannot find another reference to engine bogging down at WOT. My engine runs fine as long as I do not go WOT. I can ease up to 80-85 mph nice and smooth, but if I try WOT at any time, the engine bogs and actually seems to slow down. When I ease up on the pedal it goes back to normal.

I have changed the O2 sensor and changed the MAF. Smoke test found one vacuum leak - fixed that - Problem persists.

Has anyone ever had this problem and what did the problem turn out to be?
Reply With Quote
  #2  
Old 02-13-2019, 04:43 PM
Keller's Avatar
Keller Keller is offline
GNTTYPE Founder
 
Join Date: Jul 2004
Location: Missouri
Posts: 9,424
Keller is on a distinguished road
Question Re: Engine bogs at WOT

Is the car stock?

Does it have the stock chip?

Does it have the catalytic converter?
__________________
Scott Keller - GNTTYPE Founder & Moderator
Reply With Quote
  #3  
Old 02-13-2019, 05:33 PM
Ts86ttype's Avatar
Ts86ttype Ts86ttype is offline
Tech Support
 
Join Date: Jan 2006
Location: Washington
Posts: 652
Ts86ttype is on a distinguished road
Default Re: Engine bogs at WOT

Is the fuel filter OK??? Maybe partially plugged... Have you put a fuel pressure gauge on and test drove to see if the pressure stays up??? Tom G.
__________________
www.tomsttype.com
Grand National Diagnostic Manuals
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:37 PM.


This page maintained by: gnttype-webmaster@gnttype.org

The content, images, text and multimedia displayed and contributed by the members of the Grand National and T-Type Performance Enthusiasts Organization are Copyright ©1996-2005. No part, section, image, article or whole of this site may be reposted or redisplayed without permission of the author/contributor and/or the Grand National and T-Type Performance Enthusiasts Organization.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.