GN and T-Type Performance Enthusiasts (GNTTYPE) Forums GN and T-Type Performance Enthusiasts (GNTTYPE) Forums
This is a general site search and does not include list archives.

Go Back   GN and T-Type Performance Enthusiasts (GNTTYPE) Forums > Technical Topics > Driveability / Troubleshooting

Reply
 
Thread Tools Display Modes
  #1  
Old 03-31-2010, 08:38 PM
deus402 deus402 is offline
New Member
 
Join Date: Mar 2010
Posts: 16
deus402 is on a distinguished road
Default 85 GN Will not set DTC's but flashes code 12

like the title says, i have an 85 Grand National, it idles around 2000 RPM, and the engine bogs down under acceleration. I jumpered pins A and B on the ALDL, it flashes code 12, but no other DTC's were set. I have a mastach ALDL cable, so i decided to fire up WINALDL, so i could at least see what was going on where, but WINALDL doesn't recieve anything off of pin E of the ALDL connector.

at this point i kinda figured the ecm is smoked, but it does flash code 12 when the aldl jumpered, and when you unplug various sensors/engine controls it affects how the car idles... also, if you enter the service mode, it does switch from the fast flash to the slow flash like it's supposed to... but even when i unplug stuff that i know should set a DTC, it will not.the car will only flash dtc 12.

does all this mean that my ecm is smoked? if so can i just get another ecm and put my chip in it? if so is there a list somewhere of witch ecm's will work with my car? any other ideas what is going on here?
Reply With Quote
  #2  
Old 03-31-2010, 10:55 PM
Keller's Avatar
Keller Keller is offline
GNTTYPE Founder
 
Join Date: Jul 2004
Location: Missouri
Posts: 9,417
Keller is on a distinguished road
Exclamation Re: 85 GN Will not set DTC's but flashes code 12

First, WINALDL is somewhat of an odd piece of software. More importantly, the 84/85 ECM is an even odder piece of equipment.

There are many reasons a TR might bog: fuel delivery, ignition issues, etc. Anything from a clogged fuel filter, to a weak fuel pump, to a messed up ignition system, to a failing alternator...any of these might cause the issues you describe and never set a trouble code.

Now, the data you collect might tell a story, and help you determine the cause of the issue. Do the WOT MAF numbers look low? Do the O2 numbers at WOT numbers look low? Lots of knock retard?

The ECM can fail on these cars, but not often. I'd want to take a look at the hard data and not the codes (or lack thereof) before calling the ECM bad.
__________________
Scott Keller - GNTTYPE Founder & Moderator
Reply With Quote
  #3  
Old 04-02-2010, 02:10 AM
deus402 deus402 is offline
New Member
 
Join Date: Mar 2010
Posts: 16
deus402 is on a distinguished road
Default Re: 85 GN Will not set DTC's but flashes code 12

Quote:
Originally Posted by Keller View Post
I'd want to take a look at the hard data and not the codes (or lack thereof) before calling the ECM bad.
I concur, but there is no data stream coming off the aldl either, so there is nothing to look at.


also, when i unplug stuff that i KNOW should set a code, it doesn't.
Reply With Quote
  #4  
Old 04-02-2010, 03:35 AM
Keller's Avatar
Keller Keller is offline
GNTTYPE Founder
 
Join Date: Jul 2004
Location: Missouri
Posts: 9,417
Keller is on a distinguished road
Question Re: 85 GN Will not set DTC's but flashes code 12

That seems very suspect. What items are you unplugging? Are you doing it with the WINALDL connected or not?
__________________
Scott Keller - GNTTYPE Founder & Moderator
Reply With Quote
  #5  
Old 04-02-2010, 05:27 PM
deus402 deus402 is offline
New Member
 
Join Date: Mar 2010
Posts: 16
deus402 is on a distinguished road
Default Re: 85 GN Will not set DTC's but flashes code 12

winaldl doesn't show any data at all, so i disconnected it. with nothing jumpered/plugged in to the ALDL (i.e. just how you would normally drive it) if i unplug the MAF sensor, the SES light does not come on, and after shutting off the car and jumpering the ALDL it still only displays code 12, when it should be throwing code 34 as well... ( MASS AIR FLOW (MAF) CIRCUIT (LOW / NO SIGNAL) )

i almost wish it wasn't throwing code 12 so i would know for sure that it was the ecm or at least the aldl wiring harness...

but like i said, when i unplug the MAF the idle changes...

also, if i enter the "Field Service Mode" (see attached pic) it _will_ start flashing once per second, which allegedly confirms closed loop operation...
Attached Thumbnails
Click image for larger version

Name:	Fuel Injection System Diagnostic Circuit Check.jpg
Views:	329
Size:	200.7 KB
ID:	2032  

Last edited by deus402; 04-03-2010 at 03:32 AM. Reason: reuploaded image in jpg format
Reply With Quote
  #6  
Old 04-02-2010, 05:40 PM
deus402 deus402 is offline
New Member
 
Join Date: Mar 2010
Posts: 16
deus402 is on a distinguished road
Default Re: 85 GN Will not set DTC's but flashes code 12

I am almost sure it's the ECM now, i'm going to pull it out and see if there is anything obviously wrong... seems like the "loss of trouble code" symptom is especially relevant...

again, anyone know what vehicles i can pull an ecm out of that will work with my EEPROM?
Attached Thumbnails
Click image for larger version

Name:	1985 Grand National ECM Testing and Inspection.jpg
Views:	330
Size:	162.6 KB
ID:	2031  

Last edited by deus402; 04-03-2010 at 03:33 AM. Reason: reuploaded image in jpg format
Reply With Quote
  #7  
Old 04-02-2010, 07:46 PM
deus402 deus402 is offline
New Member
 
Join Date: Mar 2010
Posts: 16
deus402 is on a distinguished road
Default Re: 85 GN Will not set DTC's but flashes code 12

Ignore all of the above, it started displaying codes.... maybe it's on it's way out or something, but right this second, i am getting codes now. weird.
Reply With Quote
  #8  
Old 04-03-2010, 01:09 AM
deus402 deus402 is offline
New Member
 
Join Date: Mar 2010
Posts: 16
deus402 is on a distinguished road
Default Re: 85 GN Will not set DTC's but flashes code 12

really weird, ecm has been working fine all day today, i was pulling my hair out yesterday trying to get it to do anything...

thanks for the tips anyways though, it really helps to have someone to bounce ideas off of, even though it ended up fixing itself. now to get back to the acual drivability problems...
Reply With Quote
  #9  
Old 04-03-2010, 01:11 AM
deus402 deus402 is offline
New Member
 
Join Date: Mar 2010
Posts: 16
deus402 is on a distinguished road
Default Re: 85 GN Will not set DTC's but flashes code 12

yikes, i just looked at my own attachments, apparently the board software isn't too great and converting png to jpg's...
Reply With Quote
  #10  
Old 04-03-2010, 01:37 AM
Keller's Avatar
Keller Keller is offline
GNTTYPE Founder
 
Join Date: Jul 2004
Location: Missouri
Posts: 9,417
Keller is on a distinguished road
Lightbulb Re: 85 GN Will not set DTC's but flashes code 12

Well, garbage in garbage out, so to speak. The files were small pictures. No reason it should scale them up, should it?

There were not many cars that use that ECM at all. I would highly suggest you consider using the ECM used in the 86-87 cars. Much better chance you will find one in a yard, you will actually get much better scan tool data, and the ECMs are found in many more cars. That way you can pick up spare ECMs at junkyards with some chance of finding one. And the instructions for the changeover are on this site.

Pretty sure the 84-85 ones were only found in the 84-85 TRs and the Turbo Rivieras. Good luck finding one in a yard. You might find someone selling one on our pages, however.
__________________
Scott Keller - GNTTYPE Founder & Moderator
Reply With Quote
Reply

Bookmarks

Tags
aldl, dtc, ecm, idle speed, winaldl

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:27 PM.


This page maintained by: gnttype-webmaster@gnttype.org

The content, images, text and multimedia displayed and contributed by the members of the Grand National and T-Type Performance Enthusiasts Organization are Copyright ©1996-2005. No part, section, image, article or whole of this site may be reposted or redisplayed without permission of the author/contributor and/or the Grand National and T-Type Performance Enthusiasts Organization.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.