GN and T-Type Performance Enthusiasts (GNTTYPE) Forums GN and T-Type Performance Enthusiasts (GNTTYPE) Forums
This is a general site search and does not include list archives.

Go Back   GN and T-Type Performance Enthusiasts (GNTTYPE) Forums > Technical Topics > Fuel Systems

Reply
 
Thread Tools Display Modes
  #1  
Old 06-22-2015, 01:31 PM
carlu carlu is offline
New Member
 
Join Date: Oct 2014
Location: PA
Posts: 11
carlu is on a distinguished road
Default fuel pump electrical supply, 1984 T-Type

Due to failure of the fuel pump and rust issues on my 1984 T-Type, I replaced several parts of the fuel system:
gas tank
straps
pump
sock
rubber fuel lines between the tank lines and the body lines
metal fuel line that runs from above the rear axle to the bottom of the fuel filter
fuel filter.

The new fuel pump is not working. With the key on, I do not hear the pump turn on. Maybe the wiring went bad.

The wiring diagram that I found does not agree with the wiring going to the tank. I need help identifying which voltage should be on which line. There is a 3-pin connector near the rear bumper, connecting to the fuel sender assembly in the tank. tan/white, red (or pink?) and black.

A few questions:
Someone please tell me which wire carries the power to the pump.
This wire should have battery voltage for a few seconds after the key is on, right?
What is the lowest voltage acceptable coming to the pump wire to still operate the pump?
Does the pump get ground through the black wire? It must be, since there is no metal to metal contact from tank to body.

Is it safe to temporarily connect 12V and common on the pump wiring to a power source while it is installed in the tank in the car? I would wire it directly to the car battery, or to a spare battery not connected to the car electrical system. I would apply full battery voltage to the pump.

Thanks
__________________
Carl
1984 Regal T-Type
1970.5 Pontiac Firebird Formula 400
1986.5 Porsche 928
1988 Buick Reatta
2001 Oldsmobile Aurora 4.0
2004 Pontiac GTO
2012 Buick Regal 2.4L BAS-Hybrid (non-turbo)
Reply With Quote
  #2  
Old 06-22-2015, 06:29 PM
turbodave38's Avatar
turbodave38 turbodave38 is offline
Retired
 
Join Date: Jun 2005
Location: TN
Posts: 107
turbodave38 is on a distinguished road
Send a message via MSN to turbodave38
Default Re: fuel pump electrical supply, 1984 T-Type

The black wire is ground.
The pink wire is a resistance signal from the level sender.
The Tan/white wire is to supply 12v to the pump.
It wont hurt to do what you want to to test it. Just DON'T hit the pink wire with 12v.
__________________
TurboDave EWCS(SW) USN Ret
H&N Turbo Racing
Sevierville, TN
SD2 Speed Density fuel, spark and boost management
Reply With Quote
  #3  
Old 06-22-2015, 06:36 PM
kenmosher's Avatar
kenmosher kenmosher is offline
Whoosh
 
Join Date: Aug 2004
Location: CO
Posts: 3,984
kenmosher is on a distinguished road
Default Re: fuel pump electrical supply, 1984 T-Type

digging around in an old service manual for 1984 CCC (V6 turbo)...

It appears that the TAN or TAN/WHITE wire (connector 209 circuit 120) powers the pump. I'll the bet the other wires are ground and sender signal.

BLACK is ground.

I'll be there's RED wire for sender signal.
__________________
Ken Mosher
1987 GN original owner 650+ HP Black
2015 BMW 328xi XDrive wagon
2012 Volkswagen Tiguan (the Tig!) Night Blue Met (sold)
2006 Trailblazer SS Red Jewel Tint 395 HP AWD (sold)
2014 Silverado LTZ Crew 4WD
2012 Honda VFR 1200F Tahitian Blue (sold)
2015 BMW S1000R Racing Red
2013 Honda CBR500R Red (wife's bike)
2014 Triumph Bonneville T100
2003 Harley Davidson V Rod Anniversary Edition
Reply With Quote
  #4  
Old 06-23-2015, 12:23 AM
carlu carlu is offline
New Member
 
Join Date: Oct 2014
Location: PA
Posts: 11
carlu is on a distinguished road
Default Re: fuel pump electrical supply, 1984 T-Type

I got home from work and connected a lawnmower battery to the tan and black terminals. The pump ran. So I guess I have bad body wiring or a bad fuel pump relay.

Now another problem appeared. When the fuel pump pressurized the lines, some fuel leaked from the top of the tank. The fluid that came out was dark. The tank hissed even after the power to the pump was removed.

There is one new line from the tank up to the filter, and a new filter. It's hard to believe any fuel was in the rest of the system for 6+ years.

The engine did not fire up. It sputtered like it was starved for fuel. I didn't check fuel pressure.

All this is making me think I crossed up the pressure and return lines above the tank. If that was the case, I'm thinking the pressure line would see the wrong side of the regulator and the pressure would have nowhere to go. The line would have excessive pressure and find its way out somewhere.

Am I on the right track?
Reply With Quote
  #5  
Old 06-23-2015, 12:44 PM
kenmosher's Avatar
kenmosher kenmosher is offline
Whoosh
 
Join Date: Aug 2004
Location: CO
Posts: 3,984
kenmosher is on a distinguished road
Default Re: fuel pump electrical supply, 1984 T-Type

That sounds reasonable ... if you were pushing pressurized fuel up the return line, that'd do some strange stuff ... I would think that the pump would dead head against the regulator.

Put a pressure gauge on it as a quick check ... or undo the lines from the tank one at a time (into a bucket) and verify routing.
__________________
Ken Mosher
1987 GN original owner 650+ HP Black
2015 BMW 328xi XDrive wagon
2012 Volkswagen Tiguan (the Tig!) Night Blue Met (sold)
2006 Trailblazer SS Red Jewel Tint 395 HP AWD (sold)
2014 Silverado LTZ Crew 4WD
2012 Honda VFR 1200F Tahitian Blue (sold)
2015 BMW S1000R Racing Red
2013 Honda CBR500R Red (wife's bike)
2014 Triumph Bonneville T100
2003 Harley Davidson V Rod Anniversary Edition
Reply With Quote
  #6  
Old 07-11-2015, 05:25 PM
carlu carlu is offline
New Member
 
Join Date: Oct 2014
Location: PA
Posts: 11
carlu is on a distinguished road
Default Re: fuel pump electrical supply, 1984 T-Type

I checked out the lines and found that they are not crossed. The pump outlet line runs to the inlet of the fuel filter. I have a rubber fuel line piece under the frame halfway to the fuel filter and it is flowing OK up to that point.

If there was a restriction or blockage in the fuel return line, so that no fuel returned to the tank, I think the line would be at high pressure. But so high that fuel would leak at the rubber lines?
__________________
Carl
1984 Regal T-Type
1970.5 Pontiac Firebird Formula 400
1986.5 Porsche 928
1988 Buick Reatta
2001 Oldsmobile Aurora 4.0
2004 Pontiac GTO
2012 Buick Regal 2.4L BAS-Hybrid (non-turbo)
Reply With Quote
  #7  
Old 07-11-2015, 08:04 PM
carlu carlu is offline
New Member
 
Join Date: Oct 2014
Location: PA
Posts: 11
carlu is on a distinguished road
Bang Head Re: fuel pump electrical supply, 1984 T-Type

A gauge attached to the fuel rail test port shows about 9 PSI. It takes 1 to 2 seconds to climb from 0 to 9 PSI. This is with the fuel pump powered from a lawnmower battery. The battery voltage measures 12.6V.

With the fuel feed line disconnected half way to the front, the fuel flow into a can looked light (i.e. not 40 PSI).

It's a brand new fuel pump.

Nothing comes out the return line. The fuel tank is hissing after the pump is off, and fuel is trickling down the side of the tank.
__________________
Carl
1984 Regal T-Type
1970.5 Pontiac Firebird Formula 400
1986.5 Porsche 928
1988 Buick Reatta
2001 Oldsmobile Aurora 4.0
2004 Pontiac GTO
2012 Buick Regal 2.4L BAS-Hybrid (non-turbo)
Reply With Quote
  #8  
Old 07-13-2015, 12:20 PM
kenmosher's Avatar
kenmosher kenmosher is offline
Whoosh
 
Join Date: Aug 2004
Location: CO
Posts: 3,984
kenmosher is on a distinguished road
Default Re: fuel pump electrical supply, 1984 T-Type

Something is either blocking the line or the new fuel pump is not working (unlikely).

I'd look for kinks, pinches, collapsed hose (and they can collapse internally) or something misrouted.

Another thing .. try just the shortest hose you can from the top of the fuel pump and verify flow is about 1 gal/min or better with no "load" or pressure. Then move forward to the fuel filter and try it again there ... and so on.
__________________
Ken Mosher
1987 GN original owner 650+ HP Black
2015 BMW 328xi XDrive wagon
2012 Volkswagen Tiguan (the Tig!) Night Blue Met (sold)
2006 Trailblazer SS Red Jewel Tint 395 HP AWD (sold)
2014 Silverado LTZ Crew 4WD
2012 Honda VFR 1200F Tahitian Blue (sold)
2015 BMW S1000R Racing Red
2013 Honda CBR500R Red (wife's bike)
2014 Triumph Bonneville T100
2003 Harley Davidson V Rod Anniversary Edition
Reply With Quote
  #9  
Old 07-13-2015, 05:18 PM
carlu carlu is offline
New Member
 
Join Date: Oct 2014
Location: PA
Posts: 11
carlu is on a distinguished road
Unhappy Re: fuel pump electrical supply, 1984 T-Type

I found the problem. There is a pinhole in the fuel outlet line on top of the sender assembly. Where the fuel outlet line (i.e. pump pressurized output) turns horizontal after making the 90 degree bend out of the sender top plate. The pressure is being lost there, and washing the top of the tank with a fine spray of fuel.

The top side of the sender mounting plate and the three lines were very rusty so I sandblasted them before installing in the new tank. The blasting must have thinned the metal so it is porous now. When not spraying, it weeps fuel.

I painted the tank and freshly blasted sender top hoping to keep one part of the car from rusting. Amazing how quickly the paint washes away.
__________________
Carl
1984 Regal T-Type
1970.5 Pontiac Firebird Formula 400
1986.5 Porsche 928
1988 Buick Reatta
2001 Oldsmobile Aurora 4.0
2004 Pontiac GTO
2012 Buick Regal 2.4L BAS-Hybrid (non-turbo)
Reply With Quote
  #10  
Old 07-13-2015, 05:22 PM
kenmosher's Avatar
kenmosher kenmosher is offline
Whoosh
 
Join Date: Aug 2004
Location: CO
Posts: 3,984
kenmosher is on a distinguished road
Default Re: fuel pump electrical supply, 1984 T-Type

Son of a gun! I wouldn't have thought of that, but makes perfect sense. Glad to see you found it!
__________________
Ken Mosher
1987 GN original owner 650+ HP Black
2015 BMW 328xi XDrive wagon
2012 Volkswagen Tiguan (the Tig!) Night Blue Met (sold)
2006 Trailblazer SS Red Jewel Tint 395 HP AWD (sold)
2014 Silverado LTZ Crew 4WD
2012 Honda VFR 1200F Tahitian Blue (sold)
2015 BMW S1000R Racing Red
2013 Honda CBR500R Red (wife's bike)
2014 Triumph Bonneville T100
2003 Harley Davidson V Rod Anniversary Edition
Reply With Quote
Reply

Bookmarks

Tags
1984, electrical, fuel pump, key on, wiring

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 03:30 PM.


This page maintained by: gnttype-webmaster@gnttype.org

The content, images, text and multimedia displayed and contributed by the members of the Grand National and T-Type Performance Enthusiasts Organization are Copyright ©1996-2005. No part, section, image, article or whole of this site may be reposted or redisplayed without permission of the author/contributor and/or the Grand National and T-Type Performance Enthusiasts Organization.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.